Errors while installing
OpenPublic

Description

Hi There,

I'm new here so I hope I'm doing this right. I am trying to report a bug that I have found installing the GNU Social software on my Linux laptop. I hope this is the place to do that. I will try to list all the relevant information for this finding.

So,what happened?

I was installing GNU Social on my laptop. I run a number of websites on my laptop using NGINX as a webserver. In the installation proces, after an initial verification step, where I had to install the PHP Intl package, I came to a form where I had to enter some data. After doing so, this happend:

Deprecated: Non-static method PEAR::getStaticProperty() should not be called statically, assuming $this from incompatible context in /srv/www/gnu-social/extlib/DB/DataObject.php on line 4680

Deprecated: Non-static method PEAR::getStaticProperty() should not be called statically, assuming $this from incompatible context in /srv/www/gnu-social/extlib/DB/DataObject.php on line 2454

Deprecated: Non-static method PEAR::isError() should not be called statically, assuming $this from incompatible context in /srv/www/gnu-social/extlib/DB/DataObject.php on line 2478

Deprecated: Non-static method PEAR::isError() should not be called statically, assuming $this from incompatible context in /srv/www/gnu-social/extlib/DB/DataObject.php on line 2346

Deprecated: Non-static method PEAR::isError() should not be called statically, assuming $this from incompatible context in /srv/www/gnu-social/extlib/DB/DataObject.php on line 2346

Deprecated: Non-static method PEAR::isError() should not be called statically, assuming $this from incompatible context in /srv/www/gnu-social/extlib/DB/DataObject.php on line 2346

Deprecated: Non-static method PEAR::isError() should not be called statically, assuming $this from incompatible context in /srv/www/gnu-social/extlib/DB/DataObject.php on line 2346

Deprecated: Non-static method PEAR::isError() should not be called statically, assuming $this from incompatible context in /srv/www/gnu-social/extlib/DB/DataObject.php on line 2346

Deprecated: Non-static method PEAR::isError() should not be called statically, assuming $this from incompatible context in /srv/www/gnu-social/extlib/DB/DataObject.php on line 2346

Deprecated: Non-static method PEAR::isError() should not be called statically, assuming $this from incompatible context in /srv/www/gnu-social/extlib/DB/DataObject.php on line 2346

Deprecated: Non-static method PEAR::isError() should not be called statically, assuming $this from incompatible context in /srv/www/gnu-social/extlib/DB/DataObject.php on line 2346

Deprecated: Non-static method PEAR::isError() should not be called statically, assuming $this from incompatible context in /srv/www/gnu-social/extlib/DB/DataObject.php on line 2346

Deprecated: Non-static method PEAR::isError() should not be called statically, assuming $this from incompatible context in /srv/www/gnu-social/extlib/DB/DataObject.php on line 2346

Deprecated: Non-static method PEAR::isError() should not be called statically, assuming $this from incompatible context in /srv/www/gnu-social/extlib/DB/DataObject.php on line 1182

Deprecated: Non-static method PEAR::isError() should not be called statically, assuming $this from incompatible context in /srv/www/gnu-social/extlib/DB/DataObject.php on line 2346

Deprecated: Non-static method PEAR::isError() should not be called statically, assuming $this from incompatible context in /srv/www/gnu-social/extlib/DB/DataObject.php on line 1182

Deprecated: Non-static method PEAR::isError() should not be called statically, assuming $this from incompatible context in /srv/www/gnu-social/extlib/DB/DataObject.php on line 2346

Deprecated: Non-static method PEAR::isError() should not be called statically, assuming $this from incompatible context in /srv/www/gnu-social/extlib/DB/DataObject.php on line 1182

Deprecated: Non-static method PEAR::isError() should not be called statically, assuming $this from incompatible context in /srv/www/gnu-social/extlib/DB/DataObject.php on line 2346

Deprecated: Non-static method PEAR::isError() should not be called statically, assuming $this from incompatible context in /srv/www/gnu-social/extlib/DB/DataObject.php on line 1182

Deprecated: Non-static method PEAR::isError() should not be called statically, assuming $this from incompatible context in /srv/www/gnu-social/extlib/DB/DataObject.php on line 2346

Deprecated: Non-static method PEAR::raiseError() should not be called statically, assuming $this from incompatible context in /srv/www/gnu-social/extlib/Mail/mail.php on line 162

Deprecated: Non-static method PEAR::isError() should not be called statically, assuming $this from incompatible context in /srv/www/gnu-social/extlib/DB/DataObject.php on line 2346

Deprecated: Non-static method PEAR::isError() should not be called statically, assuming $this from incompatible context in /srv/www/gnu-social/extlib/DB/DataObject.php on line 1182

Deprecated: Non-static method PEAR::isError() should not be called statically, assuming $this from incompatible context in /srv/www/gnu-social/extlib/DB/DataObject.php on line 2346

Deprecated: Non-static method PEAR::isError() should not be called statically, assuming $this from incompatible context in /srv/www/gnu-social/extlib/DB/DataObject.php on line 1182

Deprecated: Non-static method PEAR::isError() should not be called statically, assuming $this from incompatible context in /srv/www/gnu-social/extlib/DB/DataObject.php on line 2346

Deprecated: Non-static method PEAR::isError() should not be called statically, assuming $this from incompatible context in /srv/www/gnu-social/extlib/DB/DataObject.php on line 1182

So yeah, lets see

$ php -v
PHP 5.6.4-4ubuntu6 (cli) (built: Apr 17 2015 15:47:51)
Copyright (c) 1997-2014 The PHP Group
Zend Engine v2.6.0, Copyright (c) 1998-2014 Zend Technologies

with Zend OPcache v7.0.4-dev, Copyright (c) 1999-2014, by Zend Technologies

$ mysql --version
mysql Ver 14.14 Distrib 5.6.24, for debian-linux-gnu (x86_64) using EditLine wrapper

$ nginx -V
nginx version: nginx/1.8.0

So, I hope this is something someone can fix easily, because it does inspire trust with new gnu-socialists, I would think...

ejfrme created this task.Via WebMay 8 2015, 4:16 AM
ejfrme added a subscriber: ejfrme.
ejfrme added a project: GNU social

Add Comment